raize.codesitelogging.dll now requires dotNET 4

CodeSite logging interface classes: default "CodeSite" logger, T|CodeSiteLogger class, destinations, formatters, etc.

raize.codesitelogging.dll now requires dotNET 4

Postby Flongrim » Tue May 12, 2015 7:40 am

In our product we have tried to be careful to avoid any dotNET version above 3.5. Since upgrading to Delphi XE7 and therefore using CodeSite 5.8, we now find that raize.codesitelogging.dll requires dotNET 4 whereas previous versions worked with dotNET 2.

Can we have a version that requires dotNET 2 again? Alternatively, can we downgrade CodeSite and still work with Delphi XE7 and Visual Studio 2013?

Thanks
Flongrim
 
Posts: 2
Joined:
Wed May 06, 2015 12:03 pm

Re: raize.codesitelogging.dll now requires dotNET 4

Postby Raize Support » Tue May 12, 2015 4:32 pm

Hi,

Yes, for the recent release of CodeSite, we did update the compiler that is used to build the assembly to .NET 4.

What version of Delphi were you using before XE7? We can provide you with an older version of the assembly that you can use, but to use CodeSite in XE7, you will need to still use the current version of CodeSite. You can simply replace the new Raize.CodeSiteLogging assembly with the older version.

Also, this particular issue is best continued via email. Please send you follow-up to support@raize.com.

Ray
Raize Software Support
Raize Software
http://www.raize.com
Raize Support
 
Posts: 622
Joined:
Fri Mar 25, 2011 9:04 pm

Re: raize.codesitelogging.dll now requires dotNET 4

Postby Flongrim » Wed May 13, 2015 10:00 am

Thanks Ray

I will continue the conversation via email as you suggest.
Flongrim
 
Posts: 2
Joined:
Wed May 06, 2015 12:03 pm


Return to Loggers

Who is online

Users browsing this forum: No registered users and 2 guests

cron