Installation in RADStudio 10.2.1

Post questions here regarding the CodeSite Express edition

Installation in RADStudio 10.2.1

Postby Keith » Wed Aug 30, 2017 9:02 pm

1) I have installed Codesite at RS install time (at least I thought I did - I see now that it was not supposed to be an option) and also by downloading and installing via GetIt Package Manager (several times).
2) At startup time the splash screen says it is loading Codesite Express Version 5.3.2
3) Programs compile and execute with CodeSite method calls
4) Codesite LiveViewer does not fire up when the program is run (as it did with XE5)
5) Codesite does NOT appear in the Tools menu
6) LiveViewer can be started manually

==> What have I done wrong?

Keith
Keith

If you have to ask if it's too early to drink wine... you're an amateur and we can't be friends.
Keith
 
Posts: 3
Joined:
Tue Aug 29, 2017 12:49 am
Location: The Wonderful Land of Oz

Re: Installation in RADStudio 10.2.1

Postby Raize Support » Sat Sep 02, 2017 9:26 am

The splash screen indicates that the CodeSite Express design package is being loaded correctly. And since programs are compiling, the Library Search path has been updated correctly during the install.

The fact that the CodeSite menu does not appear in the Tools menu indicates that the CSRadStudioTools*.dll is not being loaded. Does the CSRadStudioTools*.dll exist in the Raize\CS5\Bin directory?

Ray
Raize Software Support
Raize Software
http://www.raize.com
Raize Support
 
Posts: 611
Joined:
Fri Mar 25, 2011 9:04 pm

Re: Installation in RADStudio 10.2.1

Postby Keith » Sun Sep 03, 2017 10:04 pm

Ray

I had to update the Library Search path *in my project options* myself in order to continue compiling.

CSRadStudioTools*.dll seems to be installed in TWO directories at the moment...

C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin
contains CSRadStudioTools250.dll; CSRadStudioTools190.dll; CSRadStudioTools160.dll;
and
C:\Program Files (x86)\Raize\CS5\Bin
contains ONLY CSRadStudioTools250.dll

So something weird has happened during the installation... and its probably some temporary insanity on my part , but how the heck to I fix it?
Keith

If you have to ask if it's too early to drink wine... you're an amateur and we can't be friends.
Keith
 
Posts: 3
Joined:
Tue Aug 29, 2017 12:49 am
Location: The Wonderful Land of Oz

Re: Installation in RADStudio 10.2.1

Postby Raize Support » Tue Sep 05, 2017 9:51 am

Sorry for the delay. From what you describe it looks like older versions of CodeSite Express were installed in one directory, and then CodeSite Express was installed in a different directory and then CodeSite Express was perhaps reinstalled back into the original directory.

To fix the Tools > CodeSite menu, you need to shut down RAD Studio 10.2 Tokyo and edit the Registry. Navigate to HKEY_CURRENT_USER\Software\Embarcadero\BDS\19.0\Experts and add the following entry if it does not already exist:

Name: CodeSiteRADStudioTools
Data: C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin\CSRadStudioTools250.dll

I picked the Embarcadero\Raize directory because that looks like the one that you used for XE2 and XE5.

After making the above change, when you start RAD Studio 10.2, the CodeSite menu should be back on the Tools menu.

To fix the Live Viewer starting, we need to go back into the Registry. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Raize\CodeSite\5.0

Make sure the following values are present:

Name: Dispatcher
Data: C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin\CSDispatcher.exe

Name: InstallPath
Data: C:\Program Files (x86)\Embarcadero\Raize\CS5
I am also assuming from your message that the CSLiveViewer.exe is present in the C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin directory.

With the above change, sending a CodeSite message should cause the Live Viewer to start up if you have not changed the destination of the logger or disabled the logger.

Hope this helps,
Ray
Raize Software Support
Raize Software
http://www.raize.com
Raize Support
 
Posts: 611
Joined:
Fri Mar 25, 2011 9:04 pm

Re: Installation in RADStudio 10.2.1

Postby Keith » Wed Sep 06, 2017 1:20 am

Raize Support wrote:Sorry for the delay.


No problemo.

From what you describe it looks like older versions of CodeSite Express were installed in one directory, and then CodeSite Express was installed in a different directory and then CodeSite Express was perhaps reinstalled back into the original directory.


Yeah, at one time I was trying to keep all RAD Studio 3rd party stuff under the Embarcadero directory structure just to try to keep the program directory from getting too ridiculous. Since Codesite was Embarcadero for a while, it probably wasn't too bad an idea at the time. I suppose it just causes more trouble that it is worth now, since most folks want their own directory structure and I can't really blame them. I remember cursing out somebody in the dim dark prehistoric days (probably WIN 2000 era) about sticking things in other peoples directory and messing things up. I probably should keep to my own advice.

To fix the Tools > CodeSite menu, you need to shut down RAD Studio 10.2 Tokyo and edit the Registry. Navigate to HKEY_CURRENT_USER\Software\Embarcadero\BDS\19.0\Experts and add the following entry if it does not already exist:

Name: CodeSiteRADStudioTools
Data: C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin\CSRadStudioTools250.dll

I picked the Embarcadero\Raize directory because that looks like the one that you used for XE2 and XE5.

After making the above change, when you start RAD Studio 10.2, the CodeSite menu should be back on the Tools menu.


Worked perfectly after I used cut/paste from the File Explorer instead of the text lines above. There is a typo in there somewhere but darned if I could see it ;)

To fix the Live Viewer starting, we need to go back into the Registry. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Raize\CodeSite\5.0

Make sure the following values are present:

Name: Dispatcher
Data: C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin\CSDispatcher.exe

Name: InstallPath
Data: C:\Program Files (x86)\Embarcadero\Raize\CS5

I am also assuming from your message that the CSLiveViewer.exe is present in the C:\Program Files (x86)\Embarcadero\Raize\CS5\Bin directory.

With the above change, sending a CodeSite message should cause the Live Viewer to start up if you have not changed the destination of the logger or disabled the logger.

Hope this helps,
Ray


Again worked perfectly.

Thank you for your help. I am starting to make some progress getting my projects converted from XE5 to Tokyo (now if I could just get JEDI VCL to install I might be able to migrate away from the couple of components I use from there).

While I was fixing the CS5 entries, I looked at the Radiant Shapes and the Raize Component entries too. Their Install Path is also pointing at C:\Program Files (x86)\Raize {\RC6\ or \RadiantShapes\}. Should I reset that to ...Embarcadero\Raize\... too? The files do indeed exist there.

Come to think about it. I don't see any evidence of these guys in the IDE either. Both should be in the packages list and the tool palette yes? I don't see them at all. Boy I have really messed up this installation somehow.

And should I delete all other ...\Raize\... directories?

Or would it just be better all around to uninstall everything, delete all Raize directories still laying around, and then reinstall from scratch?

Once again thanks for your help.
Keith

If you have to ask if it's too early to drink wine... you're an amateur and we can't be friends.
Keith
 
Posts: 3
Joined:
Tue Aug 29, 2017 12:49 am
Location: The Wonderful Land of Oz

Re: Installation in RADStudio 10.2.1

Postby Raize Support » Wed Sep 06, 2017 9:40 am

Personally, I would probably uninstall and re-install into the C:\Program Files (x86)\Raize directory structure. However, you should be able to load the design packages in the RzComps\Bin and RadiantShapes\Bin directories into Delphi. Then you would simply need to add the appropriate Lib\*\Win32 directory to the Library Search Path.

Ray
Raize Software Support
Raize Software
http://www.raize.com
Raize Support
 
Posts: 611
Joined:
Fri Mar 25, 2011 9:04 pm


Return to Express Edition

Who is online

Users browsing this forum: No registered users and 1 guest