Image problem in TRzTreeView

Components on the Raize Lists palette: list boxes, check lists, combo boxes, tree views, list views, grids, etc.

Image problem in TRzTreeView

Postby qppstudio » Fri Feb 23, 2018 12:01 am

Hi,

I have 2 programs that are both compiled with Delphi 10.2.2 and display a TRzTreeView with some images from a TcxImageList. In one program the UI is modern and the images appear correctly, and in the other the images look really bad, and the UI still shows the old + signs (see attached screenshots).

I have tried to compare the PAS and DFM of each of these and cannot see any difference that would explain the attached screenshots.

I seem to recall that, at one point, in the "good" app I had to specify that Raize should use a "modern UI" or something like that, but I cannot see this option anywhere.

I am guessing that this is a small change, but cannot figure out what. Any help would be greatly appreciated.

Very best regards,

Olivier
Attachments
Bad.png
Image appear incorrectly and + are left as was in Windows XP and Delphi XE2
Bad.png (31.66 KiB) Viewed 320 times
Good.png
Image appear correctly and + are replaced by triangles
Good.png (33.34 KiB) Viewed 320 times
qppstudio
 
Posts: 5
Joined:
Wed Apr 19, 2017 1:44 pm

Re: Image problem in TRzTreeView

Postby Raize Support » Fri Feb 23, 2018 11:59 pm

Hi Olivier,

A couple things come to mind. First, check the properties of the image list controls and see if there are any differences. You could select each one in the Form Designer, copy it to the clipboard, and then paste into a text editor. Then compare the two to see if there are any differences. For example, one using a different mask for the images, etc.

The other thing to check is to see if the application is being built with themes. Check the Application settings for two projects.

Ray
Raize Software Support
Raize Software
http://www.raize.com
Raize Support
 
Posts: 613
Joined:
Fri Mar 25, 2011 9:04 pm

Re: Image problem in TRzTreeView

Postby qppstudio » Sat Feb 24, 2018 4:13 am

Hi Ray,

Thank you very much for your reply.

I tried swapping the ImageList from one project to the other and the result was the same.

But the "themes" does ring a bell, now that you mention it. However I cannot find it anywhere in my project options. Where would I have set it ?

Very best regards,

Olivier
qppstudio
 
Posts: 5
Joined:
Wed Apr 19, 2017 1:44 pm

Re: Image problem in TRzTreeView

Postby qppstudio » Sat Feb 24, 2018 4:23 am

2018-02-24_10-20-09.png
Manifest file missing common controls section
2018-02-24_10-20-09.png (103.4 KiB) Viewed 311 times
Got it !

My "bad" app's manifest file was missing the section on common controls (see attached).

Thank you for your help,

Olivier
qppstudio
 
Posts: 5
Joined:
Wed Apr 19, 2017 1:44 pm


Return to Lists

Who is online

Users browsing this forum: No registered users and 0 guests

cron